404 error when trying to add review links using Make.com

I’m getting a [404] Resource not found error when trying to setup a review link for a project. I don’t understand what I’m doing wrong and have tried to follow the documentation closely. Can anyone see my error?

Hey Tim!

Chances are the id you’re providing for the project id isn’t actually the project id.

Where did you get that UUID you’re from that you’re using?

Thanks @jhodges. I grabbed it from the module before where I created the project.

Could I also grab the project id from here too?

It doesn’t seem to matter where I get it from I still get the 404 error.

I have also confirmed that I have the right permissions.

Yup! Thats indeed the project id there in the address bar.

It should work fine to re-use the project id from the output of the previous step. There’s a very small chance it might happen too quickly in the make flow for that project to be available, but I doubt that’s the issue.

Yeah and to try and get it right I’ve now just created a single module in Make.com to just do this specific thing and I’m using the project id that I grabbed from the URL. Getting the same error though.

I’m a total novice at this stuff sorry. Can’t work out what I’m doing wrong.

I think this is your issue. Check the help text underneath, you’re not providing the URL string they’re expecting. Make implicitly adds the https://api.frame.io to the beginning of whatever route you provide here.

So the URL you’re hitting is actually going to be https://api.frame.io/https://api.frame.io/v2/projects/[your-UUID]/review_links ← which will not exist.

Ahhhh of course! They’re being too helpful! :man_facepalming:

Thanks a lot, that worked.

1 Like

Phew! Glad that’s all it was :slight_smile:.

I may reach out to Make (they built the integration) and have them modify “URL” here to “API Route” so it’s less confusing.

Yeah that’d be helpful for us newbies :pray:

Without specific details, it’s challenging to pinpoint the issue. Ensure the URL is correct, the resource exists, and permissions are set.

Double-check the documentation for any missed steps. If issues persist, consult forums or support for targeted assistance.